blenderNetworkpatreonblender-logosdheartuserthtimesbookphotopencilmap-markerchevron-rightbancommentcommentstwitterfacebookrsschainnavicongoogle-plusenvelopelinkedinmail-replycalendar-otumblrredditstumbleuponshare-altbloggerflattrflag

Cloth Simulation Fail When Exported

Cloth Simulation Fail When Exported

Postby wagnerpf » August 25th, 2011, 3:08 pm

Hello, everyone, this is my first post on the forums. So I've been having some difficulty with a cloth simulation today; when I export the the cloth object simulated to another file, for some reason the cloth will not collide with any of the objects in the other file, despite the fact that collisions are turned on for all of these objects including the cloth itself. The pinning still works. Any clue what the problem could be? I've spent hours trying to figure this one out.
wagnerpf
Starting Out
Starting Out
 
Posts: 19
Joined: August 25th, 2011, 2:56 pm

Re: Cloth Simulation Fail When Exported

Postby IrascibleOne » August 26th, 2011, 8:35 pm

Did you try re-baking the cloth?

If you bake in the original file and bring it into the new one, it will take the bake files created in the original file and totally disregard everything in the new scene. I noticed the same thing when linking/appending particles a little while ago.
Image
User avatar
IrascibleOne
Site Admin
Site Admin
 
Posts: 1543
Joined: July 31st, 2008, 7:14 pm

Re: Cloth Simulation Fail When Exported

Postby wagnerpf » August 27th, 2011, 11:22 am

I've hit the play button again and the cloth just falls through the objects, not sure if that constitutes rebaking though. How would I go about doing that?
wagnerpf
Starting Out
Starting Out
 
Posts: 19
Joined: August 25th, 2011, 2:56 pm

Re: Cloth Simulation Fail When Exported

Postby wagnerpf » August 27th, 2011, 3:11 pm

Alright so I looked up baking and I clicked "free bake" and then I clicked "bake" to bake it again. The cloth still falls through the meshes that I've turned collisions on for. What am I doing wrong lol

Edit: Does it matter that the collision modifier for everything comes after all the other modifiers? I would think that's the proper order.
wagnerpf
Starting Out
Starting Out
 
Posts: 19
Joined: August 25th, 2011, 2:56 pm

Re: Cloth Simulation Fail When Exported

Postby IrascibleOne » August 28th, 2011, 9:04 pm

I don't think the order matters, but I am not sure.

The only other thing to check, that I can think of right now, might be to see if the cloth and the collision objects are all on the same layer. If I remember correctly, if they are on different layers they will not interact with each other. For some reason I feel like I may not be right about that though. Could be something to try though, if they are indeed on different layers.
Image
User avatar
IrascibleOne
Site Admin
Site Admin
 
Posts: 1543
Joined: July 31st, 2008, 7:14 pm

Re: Cloth Simulation Fail When Exported

Postby wagnerpf » August 29th, 2011, 6:22 am

Wow thanks man! That was the problem. Strange part was I had somehow moved a couple seemingly unimportant objects to another layer, although I apparently did it in someway that allowed them to be visible in the first layer and render. Once I put everything back the cloth started colliding correctly. Thanks again!
wagnerpf
Starting Out
Starting Out
 
Posts: 19
Joined: August 25th, 2011, 2:56 pm

Re: Cloth Simulation Fail When Exported

Postby IrascibleOne » August 29th, 2011, 7:14 pm

Sweet, glad I could help!
Image
User avatar
IrascibleOne
Site Admin
Site Admin
 
Posts: 1543
Joined: July 31st, 2008, 7:14 pm
Return to Blender 3D

Who is online

Users browsing this forum: No registered users and 1 guest

cron